Caricamento foto...

WordPress 3.5 non inserisce le immagini nell’articolo

maggio 24th, 2013 by Antonio Iervolino Leave a reply »

fix-wordpress Ho aggiornato alcuni blog su piattaforma WordPress dalle precedenti versioni alla 3.5.x ed ho notato un fastidiosissimo problema nell’inserimento delle immagini nell’articolo.
La gestione dei media funziona bene, scelgo l’immagine da caricare dal mio pc, questa viene correttamente caricata e mostrata nella libreria, ma quando clicco il pulsante “inserisci nell’articolo” la finestra di gestione della library si chiude e dell’immagine nell’articolo non c’è traccia.

Cosa può essere?
Vagliamo tutte le ipotesi che mi vengono in mente, i sospettati sono:

  •  La nuova versione di WordPress
  • Il tema
  • Qualche plugin

Mi viene automatico escludere la nuova versione di WordPress ovvero la 3.5 perchè questo problema non si è presentato su tutti i blog con questa versione bensì solo ad una ristretta minoranza.
Potrebbe essere il tema? Lo sostituisco temporaneamente con il tema di default e provo, nulla è cambiato non è il tema!
Restano i plugin e fortunatamente quelli che ho attivato su uno dei blog che presenta questo problema sono pochi. Inizio a disattivarne uno alla volta e controllare se la situazione sia rimasta come prima o se sia tornato tutto a funzionare come vorrei.

Ad un certo punto l’inserimento immagine nell’articolo funziona!
Nel mio caso infatti il plugin “Flexible Lightbox” creava qualche sorta di conflitto che impediva il corretto inglobamento dell’immagine nell’editor, l’ho disabilitato! Qualche dubbio resta, prima funzionava bene con lo stesso plugin attivo, vorrà dire che il WP 3.5 e questo plugin non vanno d’accordo.

Riepilogando, qualora il vostro WordPress 3.5 non inserisse le foto nell’articolo disabilitate il plugin “Flexible Lightbox” e il problema si risolverà!

Advertisement

Lascia un commento